CVEvulnerability
CVE-2021-33036
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-06-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 9.0 HIGH — AV:N/AC:L/Au:S/C:C/I:C/A:C
- Weaknesses
- CWE-22, CWE-24, CWE-264
Description
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Affected configurations
• apache hadoop (>= 2.2.0 < 2.10.2)
• apache hadoop (>= 3.0.1 < 3.2.3)
• apache hadoop (>= 3.3.0 < 3.3.2)
• apache hadoop 3.0.0
Related
Weakness · not in database (1)
References
- http://www.openwall.com/lists/oss-security/2022/06/15/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/ctr84rmo3xd2tzqcx2b277c8z692vhl5 Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20220722-0003/ Third Party Advisory
- http://www.openwall.com/lists/oss-security/2022/06/15/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/ctr84rmo3xd2tzqcx2b277c8z692vhl5 Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20220722-0003/ Third Party Advisory