CVEvulnerability
CVE-2021-3377
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-03-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Affected configurations
• ansi up project ansi up (< 5.0.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf Exploit, Third Party Advisory
- https://github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27 Patch, Third Party Advisory
- https://doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf Exploit, Third Party Advisory
- https://github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27 Patch, Third Party Advisory
- https://security.netapp.com/advisory/ntap-20241108-0002/ security.netapp.com