CVEvulnerability

CVE-2021-3450

7.4 HIGH Published 2021-03-25 Modified 2026-10-08 Official page ↗
Status
Modified
Published
2021-03-25
Last modified
2026-10-08
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0 ([email protected])
5.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:N
Weaknesses
CWE-295

Description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Affected configurations

• openssl openssl (>= 1.1.1h < 1.1.1k) • freebsd freebsd 12.2 • netapp santricity smi-s provider firmware • netapp storagegrid firmware • windriver linux • windriver linux 17.0 • windriver linux 18.0 • windriver linux 19.0 • netapp cloud volumes ontap mediator • netapp oncommand workflow automation • netapp ontap select deploy administration utility • netapp storagegrid • fedoraproject fedora 34 • tenable nessus (<= 8.13.1) • tenable nessus agent (>= 8.2.1 <= 8.2.3) • tenable nessus network monitor 5.11.0 • tenable nessus network monitor 5.11.1 • tenable nessus network monitor 5.12.0 • tenable nessus network monitor 5.12.1 • tenable nessus network monitor 5.13.0 • oracle commerce guided search 11.3.2 • oracle enterprise manager for storage management 13.4.0.0 • oracle graalvm 19.3.5 • oracle graalvm 20.3.1.2 • oracle graalvm 21.0.0.2 • oracle jd edwards enterpriseone tools (< 9.2.6.0) • oracle jd edwards world security a9.4 • oracle mysql connectors (<= 8.0.23) • oracle mysql enterprise monitor (<= 8.0.23) • oracle mysql server (<= 5.7.33) • oracle mysql server (>= 8.0.15 <= 8.0.23) • oracle mysql workbench (<= 8.0.23) • oracle peoplesoft enterprise peopletools (>= 8.57 <= 8.59) • oracle secure backup (< 18.1.0.1.0) • oracle secure global desktop 5.6 • oracle weblogic server 12.2.1.4.0 • oracle weblogic server 14.1.1.0.0 • mcafee web gateway 8.2.19 • mcafee web gateway 9.2.10 • mcafee web gateway 10.1.1 • mcafee web gateway cloud service 8.2.19 • mcafee web gateway cloud service 9.2.10 • mcafee web gateway cloud service 10.1.1 • sonicwall sma100 firmware (< 10.2.1.0-17sv) • sonicwall capture client (< 3.6.24) • sonicwall email security (< 10.0.11) • sonicwall sonicos (<= 7.0.1-r1456) • nodejs node.js (>= 10.0.0 < 10.24.1) • nodejs node.js (>= 12.0.0 < 12.22.1) • nodejs node.js (>= 14.0.0 < 14.16.1) • nodejs node.js (>= 15.0.0 < 15.14.0)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References