CVEvulnerability

CVE-2021-37404

9.8 CRITICAL Published 2022-06-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-06-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0 ([email protected])
7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
Weaknesses
CWE-787

Description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected configurations

• apache hadoop (>= 2.9.0 < 2.10.2) • apache hadoop (>= 3.0.0 <= 3.1.4) • apache hadoop (>= 3.2.0 < 3.2.3) • apache hadoop (>= 3.3.0 < 3.3.2)

Related

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References