CVEvulnerability
CVE-2021-37633
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-08-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.4 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected configurations
• discourse discourse (< 2.7.8)
• discourse discourse 2.8.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9 Third Party Advisory
- https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9 Third Party Advisory