CVEvulnerability
CVE-2021-39171
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-08-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-400
Description
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
Affected configurations
• passport-saml project passport-saml (< 3.1.0)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/node-saml/passport-saml/pull/595 Patch, Third Party Advisory
- https://github.com/node-saml/passport-saml/security/advisories/GHSA-5379-r78w-42h2 Third Party Advisory
- https://github.com/node-saml/passport-saml/pull/595 Patch, Third Party Advisory
- https://github.com/node-saml/passport-saml/security/advisories/GHSA-5379-r78w-42h2 Third Party Advisory