CVEvulnerability
CVE-2021-39192
7.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-09-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-200, CWE-269
Description
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
Affected configurations
• ghost ghost (>= 4.0.0 < 4.10.0)
Related
References
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0 Release Notes, Third Party Advisory
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5c Third Party Advisory
- https://github.com/TryGhost/Ghost/releases/tag/v4.10.0 Release Notes, Third Party Advisory
- https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5c Third Party Advisory