CVEvulnerability
CVE-2021-39201
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-09-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in HackerOne
Affected configurations
• wordpress wordpress (>= 5.0 < 5.8)
• debian debian linux 10.0
• debian debian linux 11.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-wh69-25hr-h94v Third Party Advisory
- https://hackerone.com/reports/1142140 Permissions Required
- https://www.debian.org/security/2021/dsa-4985 Third Party Advisory
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-wh69-25hr-h94v Third Party Advisory
- https://hackerone.com/reports/1142140 Permissions Required
- https://www.debian.org/security/2021/dsa-4985 Third Party Advisory