CVEvulnerability
CVE-2021-39221
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-434, CWE-79
Description
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Contacts application prior to version 4.0.3 was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Contacts application is upgraded to 4.0.3. As a workaround, one may use a browser that has support for Content-Security-Policy.
Affected configurations
• nextcloud contacts (< 4.0.3)
Related
References
- https://github.com/nextcloud/contacts/pull/2407 Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-j6cx-mxqf-f9vc Third Party Advisory
- https://github.com/nextcloud/contacts/pull/2407 Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-j6cx-mxqf-f9vc Third Party Advisory