CVEvulnerability
CVE-2021-39222
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-11-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.3 MEDIUM — AV:N/AC:M/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-434, CWE-79
Description
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
Affected configurations
• nextcloud talk (< 10.0.7)
• nextcloud talk (>= 10.1.0 < 10.1.4)
• nextcloud talk (>= 11.0.0 < 11.1.2)
Related
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g Third Party Advisory
- https://github.com/nextcloud/spreed/pull/542 Third Party Advisory
- https://hackerone.com/reports/1135481 Permissions Required, Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g Third Party Advisory
- https://github.com/nextcloud/spreed/pull/542 Third Party Advisory
- https://hackerone.com/reports/1135481 Permissions Required, Third Party Advisory