CVEvulnerability
CVE-2021-39229
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-09-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
- Weaknesses
- CWE-400
Description
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.
Affected configurations
• nuxref apprise (< 0.9.5.1)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359 Exploit, Third Party Advisory
- https://github.com/caronc/apprise/pull/436 Patch, Third Party Advisory
- https://github.com/caronc/apprise/security/advisories/GHSA-qhmp-h54x-38qr Third Party Advisory
- https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359 Exploit, Third Party Advisory
- https://github.com/caronc/apprise/pull/436 Patch, Third Party Advisory
- https://github.com/caronc/apprise/security/advisories/GHSA-qhmp-h54x-38qr Third Party Advisory