CVEvulnerability
CVE-2021-41122
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-10-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-682
Description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
Affected configurations
• vyperlang vyper (< 0.3.0)
Related
Weakness · CWE (1)
- CWE-682 Incorrect Calculation weakness
References
- https://github.com/vyperlang/vyper/pull/2447 Third Party Advisory
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c7pr-343r-5c46 Exploit, Third Party Advisory
- https://github.com/vyperlang/vyper/pull/2447 Third Party Advisory
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c7pr-343r-5c46 Exploit, Third Party Advisory