CVEvulnerability
CVE-2021-41177
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:P
- Weaknesses
- CWE-799
Description
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.
Affected configurations
• nextcloud nextcloud server (< 20.0.13)
• nextcloud nextcloud server (>= 21.0.0 < 21.0.5)
• nextcloud nextcloud server (>= 22.0.0 < 22.2.0)
Related
Weakness · CWE (1)
- CWE-799 Improper Control of Interaction Frequency weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fj39-4qx4-m3f2 Third Party Advisory
- https://github.com/nextcloud/server/pull/28728 Patch, Third Party Advisory
- https://hackerone.com/reports/1265709 Permissions Required, Third Party Advisory
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fj39-4qx4-m3f2 Third Party Advisory
- https://github.com/nextcloud/server/pull/28728 Patch, Third Party Advisory
- https://hackerone.com/reports/1265709 Permissions Required, Third Party Advisory
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory