CVEvulnerability
CVE-2021-41178
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2021-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
- Weaknesses
- CWE-22, CWE-23, CWE-434
Description
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, a file traversal vulnerability makes an attacker able to download arbitrary SVG images from the host system, including user provided files. This could also be leveraged into a XSS/phishing attack, an attacker could upload a malicious SVG file that mimics the Nextcloud login form and send a specially crafted link to victims. The XSS risk here is mitigated due to the fact that Nextcloud employs a strict Content-Security-Policy disallowing execution of arbitrary JavaScript. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Affected configurations
• nextcloud server (>= 20.0.3 < 20.0.13)
• nextcloud server (>= 21.0.1 < 21.0.5)
• nextcloud server (>= 22.1.1 < 22.2.0)
Related
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jp9c-vpr3-m5rf Third Party Advisory
- https://github.com/nextcloud/server/pull/28726 Patch, Third Party Advisory
- https://hackerone.com/reports/1302155 Permissions Required
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jp9c-vpr3-m5rf Third Party Advisory
- https://github.com/nextcloud/server/pull/28726 Patch, Third Party Advisory
- https://hackerone.com/reports/1302155 Permissions Required
- https://security.gentoo.org/glsa/202208-17 Third Party Advisory