CVEvulnerability
CVE-2021-41230
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-11-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-863
Description
Pomerium is an open source identity-aware access proxy. In affected versions changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using `allowed_idp_claims` as part of policy. If using `allowed_idp_claims` and a user's claims are changed, Pomerium can make incorrect authorization decisions. This issue has been resolved in v0.15.6. For users unable to upgrade clear data on `databroker` service by clearing redis or restarting the in-memory databroker to force claims to be updated.
Affected configurations
• pomerium pomerium (>= 0.14.0 < 0.15.6)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/pomerium/pomerium/pull/2724 Patch, Third Party Advisory
- https://github.com/pomerium/pomerium/security/advisories/GHSA-j6wp-3859-vxfg Third Party Advisory
- https://github.com/pomerium/pomerium/pull/2724 Patch, Third Party Advisory
- https://github.com/pomerium/pomerium/security/advisories/GHSA-j6wp-3859-vxfg Third Party Advisory