CVEvulnerability

CVE-2021-4259

9.8 CRITICAL Published 2022-12-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-12-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.0 MEDIUM — CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-597

Description

A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.

Affected configurations

• phpredisadmin project phpredisadmin (< 1.16.2)

Related

Weakness · CWE (1)

  • CWE-597 Use of Wrong Operator in String Comparison weakness

References