CVEvulnerability

CVE-2021-4261

9.8 CRITICAL Published 2022-12-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-12-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-707, CWE-89

Description

A vulnerability classified as critical has been found in pacman-canvas up to 1.0.5. Affected is the function addHighscore of the file data/db-handler.php. The manipulation leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.6 is able to address this issue. The name of the patch is 29522c90ca1cebfce6453a5af5a45281d99b0646. It is recommended to upgrade the affected component. VDB-216270 is the identifier assigned to this vulnerability.

Affected configurations

• pacman-canvas project pacman-canvas (< 1.0.6)

Related

Weakness · CWE (2)

  • CWE-707 Improper Neutralization weakness
  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References