CVEvulnerability
CVE-2021-4292
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-12-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/metadata/privileges/privilege.gsp of the component Manage Privilege Page. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 4f8565425b7c74128dec9ca46dfbb9a3c1c24911. It is recommended to upgrade the affected component. The identifier VDB-216917 was assigned to this vulnerability.
Affected configurations
• openmrs admin ui module (< 1.5.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/openmrs/openmrs-module-adminui/commit/4f8565425b7c74128dec9ca46dfbb9a3c1c24911 Patch, Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/pull/58 Patch, Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.216917 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.216917 Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/commit/4f8565425b7c74128dec9ca46dfbb9a3c1c24911 Patch, Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/pull/58 Patch, Third Party Advisory
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.5.0 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.216917 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.216917 Third Party Advisory