CVEvulnerability
CVE-2021-4300
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-01-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-284
Description
A vulnerability has been found in ghostlander Halcyon and classified as critical. Affected by this vulnerability is the function CBlock::AddToBlockIndex of the file src/main.cpp of the component Block Verification. The manipulation leads to improper access controls. The attack can be launched remotely. Upgrading to version 1.1.1.0-hal is able to address this issue. The identifier of the patch is 0675b25ae9cc10b5fdc8ea3a32c642979762d45e. It is recommended to upgrade the affected component. The identifier VDB-217417 was assigned to this vulnerability.
Affected configurations
• halcyon project halcyon (< 1.1.1.0)
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/ghostlander/Halcyon/commit/0675b25ae9cc10b5fdc8ea3a32c642979762d45e Patch
- https://github.com/ghostlander/Halcyon/releases/tag/v1.1.1.0-hal Release Notes
- https://vuldb.com/?ctiid.217417 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217417 Permissions Required, Third Party Advisory
- https://github.com/ghostlander/Halcyon/commit/0675b25ae9cc10b5fdc8ea3a32c642979762d45e Patch
- https://github.com/ghostlander/Halcyon/releases/tag/v1.1.1.0-hal Release Notes
- https://vuldb.com/?ctiid.217417 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.217417 Permissions Required, Third Party Advisory