CVEvulnerability
CVE-2021-43083
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-12-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-119, CWE-191
Description
Apache PLC4X - PLC4C (Only the C language implementation was effected) was vulnerable to an unsigned integer underflow flaw inside the tcp transport. Users should update to 0.9.1, which addresses this issue. However, in order to exploit this vulnerability, a user would have to actively connect to a mallicious device which could send a response with invalid content. Currently we consider the probability of this being exploited as quite minimal, however this could change in the future, especially with the industrial networks growing more and more together.
Affected configurations
• apache plc4x (< 0.9.1)
Related
References
- http://www.openwall.com/lists/oss-security/2021/12/20/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/jxx6qc84z60xbbhn6vp2s5qf09psrtc7 Vendor Advisory
- http://www.openwall.com/lists/oss-security/2021/12/20/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/jxx6qc84z60xbbhn6vp2s5qf09psrtc7 Vendor Advisory