CVEvulnerability
CVE-2021-4374
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-06-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-862
Description
The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.
Affected configurations
• valvepress wordpress automatic plugin (<= 3.53.2)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin/ Exploit
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cve Third Party Advisory
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin/ Exploit
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cve Third Party Advisory