CVEvulnerability
CVE-2021-43778
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2021-11-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:P/I:N/A:N
- Weaknesses
- CWE-22
Description
Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.
Affected configurations
• glpi-project barcode (>= 2.0 < 2.6.1)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/hansmach1ne/MyExploits/tree/main/Path%20Traversal%20in%20GLPI%20Barcode%20plugin Exploit, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/commit/428c3d9adfb446e8492b1c2b7affb3d34072ff46 Patch, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/releases/tag/2.6.1 Release Notes, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/security/advisories/GHSA-2pjh-h828-wcw9 Patch, Third Party Advisory
- https://github.com/hansmach1ne/CVE-portfolio/tree/main/CVE-2021-43778 github.com
- https://github.com/hansmach1ne/MyExploits/tree/main/Path%20Traversal%20in%20GLPI%20Barcode%20plugin Exploit, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/commit/428c3d9adfb446e8492b1c2b7affb3d34072ff46 Patch, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/releases/tag/2.6.1 Release Notes, Third Party Advisory
- https://github.com/pluginsGLPI/barcode/security/advisories/GHSA-2pjh-h828-wcw9 Patch, Third Party Advisory