CVEvulnerability
CVE-2021-43850
6.8 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-01-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:N/A:P
- Weaknesses
- CWE-20
Description
Discourse is an open source platform for community discussion. In affected versions admins users can trigger a Denial of Service attack via the `/message-bus/_diagnostics` path. The impact of this vulnerability is greater on multisite Discourse instances (where multiple forums are served from a single application server) where any admin user on any of the forums are able to visit the `/message-bus/_diagnostics` path. The problem has been patched. Please upgrade to 2.8.0.beta10 or 2.7.12. No workarounds for this issue exist.
Affected configurations
• discourse discourse (< 2.7.12)
• discourse discourse 2.8.0
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/discourse/discourse/commit/7a8ec129fb54f188b2da6588c9d24d3a36eb0d39 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-59jr-pj65-qmvr Exploit, Third Party Advisory
- https://github.com/discourse/discourse/commit/7a8ec129fb54f188b2da6588c9d24d3a36eb0d39 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-59jr-pj65-qmvr Exploit, Third Party Advisory