CVEvulnerability
CVE-2021-44140
9.1 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2021-11-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.4 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:P
- Weaknesses
- CWE-276
Description
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.
Affected configurations
• apache jspwiki (< 2.11.0)
Related
Weakness · CWE (1)
- CWE-276 Incorrect Default Permissions weakness
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-44140 Vendor Advisory
- https://lists.apache.org/thread/5qglpjdhvobppx7j550lf1sk28f6011t Mailing List, Vendor Advisory
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-44140 Vendor Advisory
- https://lists.apache.org/thread/5qglpjdhvobppx7j550lf1sk28f6011t Mailing List, Vendor Advisory