CVEvulnerability
CVE-2021-4428
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-07-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 2.7 LOW — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 3.3 LOW — AV:N/AC:L/Au:M/C:P/I:N/A:N
- Weaknesses
- CWE-200
Description
A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.
Affected configurations
• what3words autosuggest (< 4.0.1)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac Patch
- https://github.com/what3words/wordpress-autosuggest-plugin/pull/20 Patch, Vendor Advisory
- https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1 Release Notes
- https://vuldb.com/?ctiid.234247 Permissions Required
- https://vuldb.com/?id.234247 Permissions Required
- https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac Patch
- https://github.com/what3words/wordpress-autosuggest-plugin/pull/20 Patch, Vendor Advisory
- https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1 Release Notes
- https://vuldb.com/?ctiid.234247 Permissions Required
- https://vuldb.com/?id.234247 Permissions Required