CVEvulnerability
CVE-2022-0317
3.3 LOW
Official page ↗
- Status
- Modified
- Published
- 2022-02-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.0 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 3.3 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CVSS 2.0 ([email protected])
- 2.1 LOW — AV:L/AC:L/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-20
Description
An improper input validation vulnerability in go-attestation before 0.3.3 allows local users to provide a maliciously-formed Quote over no/some PCRs, causing AKPublic.Verify to succeed despite the inconsistency. Subsequent use of the same set of PCR values in Eventlog.Verify lacks the authentication performed by quote verification, meaning a local attacker could couple this vulnerability with a maliciously-crafted TCG log in Eventlog.Verify to spoof events in the TCG log, hence defeating remotely-attested measured-boot. We recommend upgrading to Version 0.4.0 or above.
Affected configurations
• google go-attestation (< 0.3.3)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/google/go-attestation/security/advisories/GHSA-99cg-575x-774p Third Party Advisory
- https://github.com/google/go-attestation/security/advisories/GHSA-99cg-575x-774p Third Party Advisory