CVEvulnerability
CVE-2022-0451
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-02-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
- Weaknesses
- CWE-305, CWE-863
Description
Dart SDK contains the HTTPClient in dart:io library whcih includes authorization headers when handling cross origin redirects. These headers may be explicitly set and contain sensitive information. By default, HttpClient handles redirection logic. If a request is sent to example.com with authorization header and it redirects to an attackers site, they might not expect attacker site to receive authorization header. We recommend updating the Dart SDK to version 2.16.0 or beyond.
Affected configurations
• dart dart software development kit (< 2.16.0)
Related
References
- https://dart-review.googlesource.com/c/sdk/+/229947 Issue Tracking, Patch, Third Party Advisory
- https://github.com/dart-lang/sdk/commit/57db739be0ad4629079bfa94840064f615d35abc Patch, Third Party Advisory
- https://dart-review.googlesource.com/c/sdk/+/229947 Issue Tracking, Patch, Third Party Advisory
- https://github.com/dart-lang/sdk/commit/57db739be0ad4629079bfa94840064f615d35abc Patch, Third Party Advisory