CVEvulnerability
CVE-2022-1766
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-07-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-522
Description
Anchore Enterprise anchorectl version 0.1.4 improperly stored credentials when generating a Software Bill of Materials. anchorectl will add the credentials used to access Anchore Enterprise API in the Software Bill of Materials (SBOM) generated by anchorectl. Users of anchorectl version 0.1.4 should upgrade to anchorectl version 0.1.5 to resolve this issue.
Affected configurations
• anchore anchore (< 4.0.1)
• anchore anchorectl (< 0.1.5)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://docs.anchore.com/current/docs/releasenotes/401/ Release Notes, Vendor Advisory
- https://docs.anchore.com/current/docs/releasenotes/401/ Release Notes, Vendor Advisory