CVEvulnerability

CVE-2022-1941

7.5 HIGH Published 2022-09-22 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-09-22
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1286

Description

A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.

Affected configurations

• google protobuf-cpp (< 3.18.3) • google protobuf-cpp (>= 3.19.0 < 3.19.5) • google protobuf-cpp (>= 3.20.0 < 3.20.2) • google protobuf-cpp (>= 3.21.0 < 3.21.6) • google protobuf-python (< 3.18.3) • google protobuf-python (>= 3.19.0 < 3.19.5) • google protobuf-python (>= 3.20.0 < 3.20.2) • google protobuf-python (>= 4.0.0 < 4.21.6) • fedoraproject fedora 36 • fedoraproject fedora 37 • debian debian linux 10.0

Related

Weakness · CWE (1)

  • CWE-1286 Improper Validation of Syntactic Correctness of Input weakness

References