CVEvulnerability

CVE-2022-23223

7.5 HIGH Published 2022-01-25 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-01-25
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:P/I:N/A:N
Weaknesses
CWE-522

Description

On Apache ShenYu versions 2.4.0 and 2.4.1, and endpoint existed that disclosed the passwords of all users. Users are recommended to upgrade to version 2.4.2 or later.

Affected configurations

• apache shenyu 2.4.0 • apache shenyu 2.4.1

Related

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References