CVEvulnerability
CVE-2022-23516
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-12-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-674
Description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Affected configurations
• loofah project loofah (>= 2.2.0 < 2.19.1)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://github.com/flavorjones/loofah/security/advisories/GHSA-3x8r-x6xp-q4vm Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2023/09/msg00011.html lists.debian.org
- https://github.com/flavorjones/loofah/security/advisories/GHSA-3x8r-x6xp-q4vm Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2023/09/msg00011.html lists.debian.org
- https://lists.debian.org/debian-lts-announce/2024/09/msg00044.html lists.debian.org