CVEvulnerability
CVE-2022-23542
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-12-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-285
Description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.
Affected configurations
• openfga openfga (< 0.3.1)
Related
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://github.com/openfga/openfga/pull/422 Patch, Third Party Advisory
- https://github.com/openfga/openfga/releases/tag/v0.3.1 Release Notes, Third Party Advisory
- https://github.com/openfga/openfga/security/advisories/GHSA-m3q4-7qmj-657m Third Party Advisory
- https://github.com/openfga/openfga/pull/422 Patch, Third Party Advisory
- https://github.com/openfga/openfga/releases/tag/v0.3.1 Release Notes, Third Party Advisory
- https://github.com/openfga/openfga/security/advisories/GHSA-m3q4-7qmj-657m Third Party Advisory