CVEvulnerability
CVE-2022-23623
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-02-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-1321, CWE-20
Description
Frourio is a full stack framework, for TypeScript. Frourio users who uses frourio version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.
Affected configurations
• frourio frourio (< 0.26.0)
Related
References
- https://github.com/frouriojs/frourio/commit/7c19ac5363305b81b1c6b5232620228763d427af Patch, Third Party Advisory
- https://github.com/frouriojs/frourio/security/advisories/GHSA-8xxm-h73r-ghfj Third Party Advisory
- https://github.com/frouriojs/frourio/commit/7c19ac5363305b81b1c6b5232620228763d427af Patch, Third Party Advisory
- https://github.com/frouriojs/frourio/security/advisories/GHSA-8xxm-h73r-ghfj Third Party Advisory