CVEvulnerability

CVE-2022-23739

9.8 CRITICAL Published 2023-01-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-01-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-863

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server, allowing for escalation of privileges in GraphQL API requests from GitHub Apps. This vulnerability allowed an app installed on an organization to gain access to and modify most organization-level resources that are not tied to a repository regardless of granted permissions, such as users and organization-wide projects. Resources associated with repositories were not impacted, such as repository file content, repository-specific projects, issues, or pull requests. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7.1 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, 3.6.4, 3.7.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.3.16) • github enterprise server (>= 3.4.0 < 3.4.11) • github enterprise server (>= 3.5.0 < 3.5.8) • github enterprise server (>= 3.6.0 < 3.6.4) • github enterprise server 3.7.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References