CVEvulnerability

CVE-2022-23741

7.2 HIGH Published 2022-12-14 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-12-14
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-863

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a scoped user-to-server token to escalate to full admin/owner privileges. An attacker would require an account with admin access to install a malicious GitHub App. This vulnerability was fixed in versions 3.3.17, 3.4.12, 3.5.9, and 3.6.5. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.3.17) • github enterprise server (>= 3.4.0 < 3.4.12) • github enterprise server (>= 3.5.0 < 3.5.9) • github enterprise server (>= 3.6.0 < 3.6.5)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References