CVEvulnerability
CVE-2022-24748
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-03-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
- Weaknesses
- CWE-287, CWE-863
Description
Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In versions prior to 6.4.8.2 it is possible to modify customers and to create orders without App Permission. This issue is a result of improper api route checking. Users are advised to upgrade to version 6.4.8.2. There are no known workarounds.
Affected configurations
• shopware shopware (< 6.4.8.2)
Related
References
- https://github.com/shopware/core/commit/329e4d7e028dd8081496cf8bd3acc822000b0ec0 Patch, Third Party Advisory
- https://github.com/shopware/platform/security/advisories/GHSA-83vp-6jqg-6cmr Patch, Third Party Advisory
- https://github.com/shopware/core/commit/329e4d7e028dd8081496cf8bd3acc822000b0ec0 Patch, Third Party Advisory
- https://github.com/shopware/platform/security/advisories/GHSA-83vp-6jqg-6cmr Patch, Third Party Advisory