CVEvulnerability
CVE-2022-24750
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-03-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.2 HIGH — AV:L/AC:L/Au:N/C:C/I:C/A:C
- Weaknesses
- CWE-269
Description
UltraVNC is a free and open source remote pc access software. A vulnerability has been found in versions prior to 1.3.8.0 in which the DSM plugin module, which allows a local authenticated user to achieve local privilege escalation (LPE) on a vulnerable system. The vulnerability has been fixed to allow loading of plugins from the installed directory. Affected users should upgrade their UltraVNC to 1.3.8.1. Users unable to upgrade should not install and run UltraVNC server as a service. It is advisable to create a scheduled task on a low privilege account to launch WinVNC.exe instead. There are no known workarounds if winvnc needs to be started as a service.
Affected configurations
• uvnc ultravnc (< 1.3.8.1)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPE Patch, Third Party Advisory
- https://github.com/ultravnc/UltraVNC/commit/36a31b37b98f70c1db0428f5ad83170d604fb352 Patch, Third Party Advisory
- https://github.com/ultravnc/UltraVNC/security/advisories/GHSA-3mvp-cp5x-vj5g Third Party Advisory
- https://github.com/bowtiejicode/UltraVNC-DSMPlugin-LPE Patch, Third Party Advisory
- https://github.com/ultravnc/UltraVNC/commit/36a31b37b98f70c1db0428f5ad83170d604fb352 Patch, Third Party Advisory
- https://github.com/ultravnc/UltraVNC/security/advisories/GHSA-3mvp-cp5x-vj5g Third Party Advisory