CVEvulnerability

CVE-2022-24775

7.5 HIGH Published 2022-03-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-03-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0 ([email protected])
5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:P/A:N
Weaknesses
CWE-20

Description

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Affected configurations

• drupal drupal (>= 8.0.0 < 9.2.16) • drupal drupal (>= 9.3.0 < 9.3.9) • guzzlephp psr-7 (< 1.8.4) • guzzlephp psr-7 (>= 2.0.0 < 2.1.1)

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References