CVEvulnerability
CVE-2022-24783
10.0 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-03-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 10.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-269, CWE-863
Description
Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There is no workaround. All users are recommended to upgrade to 1.20.3 immediately.
Affected configurations
• deno deno (>= 1.18.0 < 1.20.3)
Related
References
- https://github.com/denoland/deno/security/advisories/GHSA-838h-jqp6-cf2f Third Party Advisory
- https://github.com/denoland/deno/security/advisories/GHSA-838h-jqp6-cf2f Third Party Advisory