CVEvulnerability
CVE-2022-24806
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-04-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a user with read-write credentials can exploit an Improper Input Validation vulnerability when SETing malformed OIDs in master agent and subagent simultaneously. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.
Affected configurations
• net-snmp net-snmp (< 5.9.2)
• fedoraproject fedora 35
• fedoraproject fedora 36
• debian debian linux 10.0
• debian debian linux 11.0
• redhat enterprise linux 9.0
• redhat enterprise linux eus 9.2
• redhat enterprise linux eus 9.4
• redhat enterprise linux for arm 64 9.0
• redhat enterprise linux for arm 64 9.2 aarch64
• redhat enterprise linux for arm 64 9.4 aarch64
• redhat enterprise linux for arm 64 eus 9.4 aarch64
• redhat enterprise linux for ibm z systems 9.0
• redhat enterprise linux for ibm z systems 9.2 s390x
• redhat enterprise linux for ibm z systems 9.4 s390x
• redhat enterprise linux for ibm z systems eus 9.4 s390x
• redhat enterprise linux for power little endian 9.0
• redhat enterprise linux for power little endian eus 9.2 ppc64le
• redhat enterprise linux for power little endian eus 9.4 ppc64le
• redhat enterprise linux server aus 9.2
• redhat enterprise linux server aus 9.4
• redhat enterprise linux server for power little endian update services for sap solutions 9.2 ppc64le
• redhat enterprise linux server update services for sap solutions 9.2
• redhat enterprise linux update services for sap solutions 9.4
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2103225 Third Party Advisory
- https://github.com/net-snmp/net-snmp/commit/ce66eb97c17aa9a48bc079be7b65895266fa6775 Patch
- https://lists.debian.org/debian-lts-announce/2022/08/msg00020.html Third Party Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FX75KKGMO5XMV6JMQZF6KOG3JPFNQBY7/ Product
- https://security.gentoo.org/glsa/202210-29 Third Party Advisory
- https://www.debian.org/security/2022/dsa-5209 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=2103225 Third Party Advisory
- https://github.com/net-snmp/net-snmp/commit/ce66eb97c17aa9a48bc079be7b65895266fa6775 Patch
- https://lists.debian.org/debian-lts-announce/2022/08/msg00020.html Third Party Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FX75KKGMO5XMV6JMQZF6KOG3JPFNQBY7/ Product
- https://security.gentoo.org/glsa/202210-29 Third Party Advisory
- https://www.debian.org/security/2022/dsa-5209 Third Party Advisory