CVEvulnerability
CVE-2022-24898
4.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-04-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:P/I:N/A:N
- Weaknesses
- CWE-611
Description
org.xwiki.commons:xwiki-commons-xml is a common module used by other XWiki top level projects. Starting in version 2.7 and prior to versions 12.10.10, 13.4.4, and 13.8-rc-1, it is possible for a script to access any file accessing to the user running XWiki application server with XML External Entity Injection through the XML script service. The problem has been patched in versions 12.10.10, 13.4.4, and 13.8-rc-1. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.
Affected configurations
• xwiki commons (>= 2.7 < 12.10.10)
• xwiki commons (>= 13.0 < 13.4.4)
• xwiki commons (>= 13.5 < 13.8)
Related
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://github.com/xwiki/xwiki-commons/commit/947e8921ebd95462d5a7928f397dd1b64f77c7d5 Patch, Third Party Advisory
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-m2r5-4w96-qxg5 Third Party Advisory
- https://jira.xwiki.org/browse/XWIKI-18946 Exploit, Vendor Advisory
- https://github.com/xwiki/xwiki-commons/commit/947e8921ebd95462d5a7928f397dd1b64f77c7d5 Patch, Third Party Advisory
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-m2r5-4w96-qxg5 Third Party Advisory
- https://jira.xwiki.org/browse/XWIKI-18946 Exploit, Vendor Advisory