CVEvulnerability
CVE-2022-25243
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-03-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 2.0 ([email protected])
- 3.5 LOW — AV:N/AC:M/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-295
Description
"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.
Affected configurations
• hashicorp vault (>= 1.8.0 < 1.8.9)
• hashicorp vault (>= 1.9.0 < 1.9.4)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://discuss.hashicorp.com Vendor Advisory
- https://discuss.hashicorp.com/t/hcsec-2022-09-vault-pki-secrets-engine-policy-results-in-incorrect-wildcard-certificate-issuance/36600 Mitigation, Vendor Advisory
- https://security.gentoo.org/glsa/202207-01 Third Party Advisory
- https://discuss.hashicorp.com Vendor Advisory
- https://discuss.hashicorp.com/t/hcsec-2022-09-vault-pki-secrets-engine-policy-results-in-incorrect-wildcard-certificate-issuance/36600 Mitigation, Vendor Advisory
- https://security.gentoo.org/glsa/202207-01 Third Party Advisory