CVEvulnerability
CVE-2022-27479
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-04-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-89
Description
Apache Superset before 1.4.2 is vulnerable to SQL injection in chart data requests. Users should update to 1.4.2 or higher which addresses this issue.
Affected configurations
• apache superset (< 1.4.2)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- http://www.openwall.com/lists/oss-security/2022/04/13/3 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/94th50j5d0y2fw7ysx0g7w3t6jk3z7q6 Broken Link
- https://lists.apache.org/thread/ztb9b6jd9rngoxwvq8r4fhpp401o613y Broken Link
- http://www.openwall.com/lists/oss-security/2022/04/13/3 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/94th50j5d0y2fw7ysx0g7w3t6jk3z7q6 Broken Link
- https://lists.apache.org/thread/ztb9b6jd9rngoxwvq8r4fhpp401o613y Broken Link