CVEvulnerability
CVE-2022-28366
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-04-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 5.0 MEDIUM — AV:N/AC:L/Au:N/C:N/I:N/A:P
Description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Affected configurations
• cyberneko html project cyberneko html (<= 1.9.22)
• htmlunit htmlunit (< 2.27)
• antisamy project antisamy (< 1.6.6)
References
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6 Release Notes, Third Party Advisory
- https://search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit Release Notes, Third Party Advisory
- https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/ Release Notes, Third Party Advisory
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6 Release Notes, Third Party Advisory
- https://search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit Release Notes, Third Party Advisory
- https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/ Release Notes, Third Party Advisory