CVEvulnerability
CVE-2022-29256
6.7 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-05-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 6.7 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 4.6 MEDIUM — AV:L/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-77, CWE-78
Description
sharp is an application for Node.js image processing. Prior to version 0.30.5, there is a possible vulnerability in logic that is run only at `npm install` time when installing versions of `sharp` prior to the latest v0.30.5. If an attacker has the ability to set the value of the `PKG_CONFIG_PATH` environment variable in a build environment then they might be able to use this to inject an arbitrary command at `npm install` time. This is not part of any runtime code, does not affect Windows users at all, and is unlikely to affect anyone that already cares about the security of their build environment. This problem is fixed in version 0.30.5.
Affected configurations
• sharp project sharp (< 0.30.5)
Related
References
- https://github.com/lovell/sharp/commit/a6aeef612be50f5868a77481848b1de674216f0c Patch, Third Party Advisory
- https://github.com/lovell/sharp/security/advisories/GHSA-gp95-ppv5-3jc5 Patch, Third Party Advisory
- https://github.com/lovell/sharp/commit/a6aeef612be50f5868a77481848b1de674216f0c Patch, Third Party Advisory
- https://github.com/lovell/sharp/security/advisories/GHSA-gp95-ppv5-3jc5 Patch, Third Party Advisory