CVEvulnerability
CVE-2022-31076
5.7 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-06-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.2 MEDIUM — CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 5.7 MEDIUM — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 2.0 ([email protected])
- 2.7 LOW — AV:A/AC:L/Au:S/C:N/I:N/A:P
- Weaknesses
- CWE-476
Description
KubeEdge is built upon Kubernetes and extends native containerized application orchestration and device management to hosts at the Edge. In affected versions a malicious message can crash CloudCore by triggering a nil-pointer dereference in the UDS Server. Since the UDS Server only communicates with the CSI Driver on the cloud side, the attack is limited to the local host network. As such, an attacker would already need to be an authenticated user of the Cloud. Additionally it will be affected only when users turn on the unixsocket switch in the config file cloudcore.yaml. This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. Users unable to upgrade should sisable the unixsocket switch of CloudHub in the config file cloudcore.yaml.
Affected configurations
• linuxfoundation kubeedge (< 1.9.3)
• linuxfoundation kubeedge 1.10.0
Related
Weakness · CWE (1)
- CWE-476 NULL Pointer Dereference weakness
References
- https://github.com/kubeedge/kubeedge/pull/3899/commits/5d60ae9eabd6b6b7afe38758e19bbe8137664701 Patch, Third Party Advisory
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-8f4f-v9x5-cg6j Exploit, Third Party Advisory
- https://github.com/kubeedge/kubeedge/pull/3899/commits/5d60ae9eabd6b6b7afe38758e19bbe8137664701 Patch, Third Party Advisory
- https://github.com/kubeedge/kubeedge/security/advisories/GHSA-8f4f-v9x5-cg6j Exploit, Third Party Advisory