CVEvulnerability
CVE-2022-31106
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-06-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-1321, CWE-915
Description
Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.
Affected configurations
• clever underscore.deep (< 0.5.3)
Related
References
- https://github.com/Clever/underscore.deep/commit/b5e109ad05b48371be225fa4d490dd08a94e8ef7 Patch, Third Party Advisory
- https://github.com/Clever/underscore.deep/security/advisories/GHSA-8j79-hfj5-f2xm Exploit, Issue Tracking, Patch, Third Party Advisory
- https://github.com/Clever/underscore.deep/commit/b5e109ad05b48371be225fa4d490dd08a94e8ef7 Patch, Third Party Advisory
- https://github.com/Clever/underscore.deep/security/advisories/GHSA-8j79-hfj5-f2xm Exploit, Issue Tracking, Patch, Third Party Advisory