CVEvulnerability
CVE-2022-31115
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-06-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-502
Description
opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a result opensearch-ruby 2.0.0 and prior can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability. The problem has been patched in opensearch-ruby gem version 2.0.1. Users are advised to upgrade. There are no known workarounds for this issue.
Affected configurations
• amazon opensearch (< 2.0.2)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://github.com/opensearch-project/opensearch-ruby/pull/77 Patch, Third Party Advisory
- https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3 Third Party Advisory
- https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ Exploit, Third Party Advisory
- https://github.com/opensearch-project/opensearch-ruby/pull/77 Patch, Third Party Advisory
- https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3 Third Party Advisory
- https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/ Exploit, Third Party Advisory