CVEvulnerability
CVE-2022-31148
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-08-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.
Affected configurations
• shopware shopware (>= 5.7.0 < 5.7.14)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022 Vendor Advisory
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf Patch, Third Party Advisory
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw Third Party Advisory
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022 Vendor Advisory
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf Patch, Third Party Advisory
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw Third Party Advisory