CVEvulnerability
CVE-2022-31181
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-08-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74, CWE-89
Description
PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.
Affected configurations
• prestashop prestashop (>= 1.6.0.10 < 1.7.8.7)
Related
References
- https://github.com/PrestaShop/PrestaShop/commit/b6d96e7c2a4e35a44e96ffbcdfd34439b56af804 Patch, Third Party Advisory
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.8.7 Release Notes, Third Party Advisory
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-hrgx-p36p-89q4 Mitigation, Third Party Advisory
- https://github.com/PrestaShop/PrestaShop/commit/b6d96e7c2a4e35a44e96ffbcdfd34439b56af804 Patch, Third Party Advisory
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.8.7 Release Notes, Third Party Advisory
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-hrgx-p36p-89q4 Mitigation, Third Party Advisory